Back to overview
Server issue
Aug 26 at 03:05am HDT
Affected services
TechboltX-Main
Resolved
Aug 26 at 03:05am HDT
We contacted the server provider and resolved the data base server down.
Affected services
Resolved
Aug 26 at 03:05am HDT
We contacted the server provider and resolved the data base server down.
Affected services